Discussion:
No board configuration seems to be building.
(too old to reply)
vladradulescubv@yahoo.com [nuttx]
2018-02-06 21:57:37 UTC
Permalink
So I started working with NUTTX on arch linux and tried setting up a canned configuration and building.

The thing is I get build errors, it says :

LN: include/arch to arch/arm/include
include/arch already exists but is not a symbolic link
make: *** [Makefile.unix:290: include/arch] Error 1

I tried this with about 5 configurations and the same deal with all of them.

It's wierd, I could swer this worked out of the box previously, when I was building on a ubuntu system.

Any ideeas what could be wrong? Am I missign something in my system? Any pointers where I should poke around would be very usefull.

Thank you,
Vlad R.
spudarnia@yahoo.com [nuttx]
2018-02-06 22:17:42 UTC
Permalink
Post by ***@yahoo.com [nuttx]
LN: include/arch to arch/arm/include
include/arch already exists but is not a symbolic link
make: *** [Makefile.unix:290: include/arch] Error 1
That message comes from tools/link.sh under these circumstances:

The directory include/arch exists and is not a symbolic link. You should remove it via "rm -rf include/arch"

The probable situation is that you not setting up the configurations correctly on you platform and have corrupted the directory structures.. First you need do

make distclean

And if it complains about being unable to remove a directory, you need to remove those manually.

Then reinstall the configuration. On Linux, you do that like:

tools/configure.sh -l <board>/<config>

Where -l means to configure for the Linux platform. If you are using Cygwin under windows, you would do:

tools/configure.sh -c <board>/<config>

Do 'tools/configure.sh -h' for other options.

Do not enter 'make' with assure that you have the correct configuration for your host platform or you will again corrupt the directory structure. For the case of Cygwin, you also need to check the what kind of toolchain you are using: (1) You might be using a Cygwin native toolchain such as the the NuttX buildroot tool chain built under Cygwin. These tools can follow Cygwin symbolic links. Or (2) a Windows native tool chain that you may have downloaded and installed on windows. These cannot follow Cygwin symbolic links and have to copy directories.

To select the toolchain, do 'make menuconfig' and select the correctly toolchain under the 'System Type' menu.

This is all discussed in excruciating detail in the top-level README.txt. If you keep configuring the board configurations wrong, you will need getting the same result (especially if you don't fix the directory structure after it has been corrupted by trying to make a bad configuration).
vladradulescubv@yahoo.com [nuttx]
2018-02-13 17:17:52 UTC
Permalink
Thanks for the pointers, spudarnia, indeed, it was my fault that i ran the configuration with the wrong build system setup and only _after_ that I modified the configuration and expected it to work. I didn't expect that it messed up the directory structure and had to run a distclean

configure.sh -l didn't work, the option -l was unknowd but that is because I was using the nuttx-7.9 release tag and I think that option was a more recent addition.

Thank you again for the pointers,
Vlad R.

Loading...